Una función es una fórmula predefinida por Excel 2007 (o por el usuario) que opera con uno o más valores y
devuelve un resultado
que aparecerá directamente en la celda o será utilizado para calcular la fórmula que la contiene.

La sintaxis de cualquier función es:

nombre_función(argumento1;argumento2;...;argumentoN)

Siguen las siguientes reglas:

- Si la función va al comienzo de una fórmula debe empezar por el signo =.
- Los argumentos o valores de entrada van siempre entre paréntesis. No dejes espacios antes o después
de cada paréntesis.
- Los argumentos pueden ser valores constantes (número o texto), fórmulas o funciones.
- Los argumentos deben de separarse por un punto y coma ;.

Ejemplo: =SUMA(A1:C8)
Tenemos la función SUMA() que devuelve como resultado la suma de sus argumentos. El operador ":" nos identifica
un rango de celdas
, así A1:C8 indica todas las celdas incluidas entre la celda A1 y la C8, así la función anterior sería
equivalente a:

=A1+A2+A3+A4+A5+A6+A7+A8+B1+B2+B3+B4+B5+B6+B7+B8+C1+C2+C3+C4+C5+C6+C7+C8

En este ejemplo se puede apreciar la ventaja de utilizar la función.
Las fórmulas pueden contener más de una función, y pueden aparecer funciones anidadas dentro de la fórmula.

Ejemplo: =SUMA(A1:B4)/SUMA(C1:D4)

Existen muchos tipos de funciones dependiendo del tipo de operación o cálculo que realizan. Así hay funciones matemáticas
y trigonométricas, estadísticas, financieras, de texto, de fecha y hora, lógicas, de base de datos, de búsqueda y referencia
y de información.
Para introducir una fórmula debe escribirse en una celda cualquiera tal cual introducimos cualquier texto, precedida siempre
del signo =.


Insertar función con el asistente


Una función como cualquier dato se puede escribir directamente en la celda si conocemos su sintaxis, pero Excel 2007 dispone
de una ayuda o asistente para utilizarlas, así nos resultará más fácil trabajar con ellas.
Si queremos introducir una función en una celda:
external image orangeball.gif Situarse en la celda donde queremos introducir la función.
Hacer clic en la pestaña Fórmulas.
Elegir la opción Insertar función.

insertar_funcion.gif

external image orangeball.gif O bien, hacer clic sobre el botón
boton formulas
boton formulas
de la barra de fórmulas.
Aparecerá el siguiente cuadro de diálogo Insertar función:



0.gif

Excel 2007 nos permite buscar la función que necesitamos escribiendo una breve descripción de la función necesitada en el
recuadro Buscar una función: y a continuación hacer clic sobre el botón
boton ir
boton ir
, de esta forma no es necesario
conocer cada una de las funciones que incorpora Excel ya que el nos mostrará en el cuadro de lista Seleccionar una función:
las funciones que tienen que ver con la descripción escrita.
Para que la lista de funciones no sea tan extensa podemos seleccionar previamente una categoría del cuadro combinado O
seleccionar una categoría:
, esto hará que en el cuadro de lista sólo aparezcan las funciones de la categoría elegida y reduzca
por lo tanto la lista. Si no estamos muy seguros de la categoría podemos elegir Todas.
En el cuadro de lista Seleccionar una función: hay que elegir la función que deseamos haciendo clic sobre ésta.
Observa como conforme seleccionamos una función, en la parte inferior nos aparecen los distintos argumentos y una breve
descripción de ésta. También disponemos de un enlace Ayuda sobre esta función para obtener una descripción más completa
de dicha función.
A final, hacer clic sobre el botón Aceptar.


Vea también:
Excel 2007